我经常使用gitbook制作各种文档,包括需求文档和产品文档,以及接口文档等。

今天在使用gitbook serve命令时候 报了一个错误:

cb.apply错误,以前没有遇到过,最近也没有更新过gitbook版本,但是突然想到前段时间安装Nginx的时候好像升级了node到最新版,经过查询,网上的方法大多数都是降级node版本,

但是我又不想降级,怕影响我Nginx环境。

我直接打开报错目录

查看了一下polyfills.js内容,报错行数287行,代码如下:

 

这段代码应该是修改旧版本的问题的,导致的报错,但是其实并不需要修复。我直接查看他的调用,发现了62-64行调用代码,直接注释:

保存后运行gitbook serve, 成功如下:

 

over.


丶伊眸冷

静水流深,沧笙踏歌;三生阴晴圆缺,一朝悲欢离合。

发表评论

电子邮件地址不会被公开。 必填项已用*标注

我不是机器人*